How to fix VMware /usr/lib/vmware/bin/appLoader crash (can’t compile modules)

Unfortunately, each time I upgrade Ubuntu with a new kernel, I must re-compile the modules used by VMware to get it to boot.

kernel recompile warning
kernel recompile warning

Pressing install won’t correctly compile the modules, resulting in a crash:

crash report of vmware apploader
crash report of vmware apploader

This is caused by the /usr/lib/vmware/bin/appLoader executable, linked by /usr/lib/vmware/bin/vmware-gksu, which FAILS to execute:

vmware apploader output
vmware apploader output

I didn’t have time to search the root cause of the problem, so I found a workaround: calling vmware-modconfig –console –install-all with root priviledges:

vmware modules compilation
vmware modules compilation

Once compilation is finished, you can boot VMware normally again 🙂

vmware boot
vmware boot
Annunci